Degraded performance
Incident Report for Cosmic JS
Resolved
This incident has been resolved.
Posted almost 2 years ago. Nov 22, 2017 - 06:58 UTC
Identified
Degraded performance due to friendly fire DDOS
Posted almost 2 years ago. Nov 22, 2017 - 06:53 UTC